image: ignore errors from mktplinkfw command
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 10:21:58 +0000 (11:21 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 13:17:33 +0000 (14:17 +0100)
Rework tplink-v2-header and tplink-v2-image Build define to ignore error
if mktplinkfw2 errors out.

This is to handle situation when the image is too big and can't be
generated or prev check-image calls deleted the source file as it's too
big.

This aligns to the pattern used by tplink-v1-image.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/image-commands.mk

index d2974f4e0150bb143d038194a01284bb89297143..702cbd8c98999a0d6e0a2dd56f3c71be142be0b1 100644 (file)
@@ -666,23 +666,22 @@ define Build/tplink-v1-image
 endef
 
 define Build/tplink-v2-header
-       $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
                -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
                -E $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR))  \
                -w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
                -T $(TPLINK_HVERSION) -V "ver. 2.0" \
-               -k $@ -o $@.new $(1)
-       @mv $@.new $@
+               -k $@ -o $@.new $(1) \
+       && mv $@.new $@ || rm -f $@
 endef
 
 define Build/tplink-v2-image
-       $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
                -H $(TPLINK_HWID) -W $(TPLINK_HWREV) \
                -w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
                -T $(TPLINK_HVERSION) -V "ver. 2.0" -a 0x4 -j \
-               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new $(1)
-       cat $@.new >> $@
-       rm -rf $@.new
+               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new $(1) \
+       && cat $@.new >> $@ && rm -rf $@.new || rm -f $@
 endef
 
 define Build/uImage