libdlna: fix build failure introduced by [21056], restore fix from [12678] (closes...
authorNicolas Thill <nico@openwrt.org>
Wed, 28 Apr 2010 01:39:26 +0000 (01:39 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 28 Apr 2010 01:39:26 +0000 (01:39 +0000)
SVN-Revision: 21215

libs/libdlna/Makefile

index a2b6989a8bafb1e6e9f89d25c5e58d68301b6b9f..a805dd753bbf450bef2ebced6d9e27e6f878c9ea 100644 (file)
@@ -39,7 +39,7 @@ define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS) -lpthread -lz" \
+               LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
                HOST_CC="$(HOSTCC)" \
                ./configure \
                --cross-compile \
@@ -53,6 +53,11 @@ define Build/Configure
        )
 endef
 
+# XXX: fix build on systems where install is not at its usual location
+# INSTALL defaults to /usr/bin/install
+MAKE_INSTALL_FLAGS += \
+       INSTALL="install" \
+
 TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev