selftests/bpf: Move test_queue_stack_map.h into progs/ where it belongs
authorAndrii Nakryiko <andriin@fb.com>
Wed, 16 Oct 2019 06:00:50 +0000 (23:00 -0700)
committerAlexei Starovoitov <ast@kernel.org>
Thu, 17 Oct 2019 19:15:08 +0000 (12:15 -0700)
test_queue_stack_map.h is used only from BPF programs. Thus it should be
part of progs/ subdir. An added benefit of moving it there is that new
TEST_RUNNER_DEFINE_RULES macro-rule will properly capture dependency on
this header for all BPF objects and trigger re-build, if it changes.

Signed-off-by: Andrii Nakryiko <andriin@fb.com>
Signed-off-by: Alexei Starovoitov <ast@kernel.org>
Link: https://lore.kernel.org/bpf/20191016060051.2024182-7-andriin@fb.com
tools/testing/selftests/bpf/Makefile
tools/testing/selftests/bpf/progs/test_queue_stack_map.h [new file with mode: 0644]
tools/testing/selftests/bpf/test_queue_stack_map.h [deleted file]

index c9f43d49eac985c58b0d24c99552c85800547483..16056e5d399d0c060612b055423729a656fbe2ff 100644 (file)
@@ -153,9 +153,6 @@ CLANG_CFLAGS = $(CLANG_SYS_INCLUDES) \
 $(OUTPUT)/test_l4lb_noinline.o: BPF_CFLAGS += -fno-inline
 $(OUTPUT)/test_xdp_noinline.o: BPF_CFLAGS += -fno-inline
 
-$(OUTPUT)/test_queue_map.o: test_queue_stack_map.h
-$(OUTPUT)/test_stack_map.o: test_queue_stack_map.h
-
 $(OUTPUT)/flow_dissector_load.o: flow_dissector_load.h
 
 # Build BPF object using Clang
diff --git a/tools/testing/selftests/bpf/progs/test_queue_stack_map.h b/tools/testing/selftests/bpf/progs/test_queue_stack_map.h
new file mode 100644 (file)
index 0000000..0e014d3
--- /dev/null
@@ -0,0 +1,59 @@
+/* SPDX-License-Identifier: GPL-2.0 */
+// Copyright (c) 2018 Politecnico di Torino
+#include <stddef.h>
+#include <string.h>
+#include <linux/bpf.h>
+#include <linux/if_ether.h>
+#include <linux/ip.h>
+#include <linux/pkt_cls.h>
+#include "bpf_helpers.h"
+
+int _version SEC("version") = 1;
+
+struct {
+       __uint(type, MAP_TYPE);
+       __uint(max_entries, 32);
+       __uint(map_flags, 0);
+       __uint(key_size, 0);
+       __uint(value_size, sizeof(__u32));
+} map_in SEC(".maps");
+
+struct {
+       __uint(type, MAP_TYPE);
+       __uint(max_entries, 32);
+       __uint(map_flags, 0);
+       __uint(key_size, 0);
+       __uint(value_size, sizeof(__u32));
+} map_out SEC(".maps");
+
+SEC("test")
+int _test(struct __sk_buff *skb)
+{
+       void *data_end = (void *)(long)skb->data_end;
+       void *data = (void *)(long)skb->data;
+       struct ethhdr *eth = (struct ethhdr *)(data);
+       __u32 value;
+       int err;
+
+       if (eth + 1 > data_end)
+               return TC_ACT_SHOT;
+
+       struct iphdr *iph = (struct iphdr *)(eth + 1);
+
+       if (iph + 1 > data_end)
+               return TC_ACT_SHOT;
+
+       err = bpf_map_pop_elem(&map_in, &value);
+       if (err)
+               return TC_ACT_SHOT;
+
+       iph->daddr = value;
+
+       err = bpf_map_push_elem(&map_out, &iph->saddr, 0);
+       if (err)
+               return TC_ACT_SHOT;
+
+       return TC_ACT_OK;
+}
+
+char _license[] SEC("license") = "GPL";
diff --git a/tools/testing/selftests/bpf/test_queue_stack_map.h b/tools/testing/selftests/bpf/test_queue_stack_map.h
deleted file mode 100644 (file)
index 0e014d3..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-/* SPDX-License-Identifier: GPL-2.0 */
-// Copyright (c) 2018 Politecnico di Torino
-#include <stddef.h>
-#include <string.h>
-#include <linux/bpf.h>
-#include <linux/if_ether.h>
-#include <linux/ip.h>
-#include <linux/pkt_cls.h>
-#include "bpf_helpers.h"
-
-int _version SEC("version") = 1;
-
-struct {
-       __uint(type, MAP_TYPE);
-       __uint(max_entries, 32);
-       __uint(map_flags, 0);
-       __uint(key_size, 0);
-       __uint(value_size, sizeof(__u32));
-} map_in SEC(".maps");
-
-struct {
-       __uint(type, MAP_TYPE);
-       __uint(max_entries, 32);
-       __uint(map_flags, 0);
-       __uint(key_size, 0);
-       __uint(value_size, sizeof(__u32));
-} map_out SEC(".maps");
-
-SEC("test")
-int _test(struct __sk_buff *skb)
-{
-       void *data_end = (void *)(long)skb->data_end;
-       void *data = (void *)(long)skb->data;
-       struct ethhdr *eth = (struct ethhdr *)(data);
-       __u32 value;
-       int err;
-
-       if (eth + 1 > data_end)
-               return TC_ACT_SHOT;
-
-       struct iphdr *iph = (struct iphdr *)(eth + 1);
-
-       if (iph + 1 > data_end)
-               return TC_ACT_SHOT;
-
-       err = bpf_map_pop_elem(&map_in, &value);
-       if (err)
-               return TC_ACT_SHOT;
-
-       iph->daddr = value;
-
-       err = bpf_map_push_elem(&map_out, &iph->saddr, 0);
-       if (err)
-               return TC_ACT_SHOT;
-
-       return TC_ACT_OK;
-}
-
-char _license[] SEC("license") = "GPL";