mvebu: omnia: make initramfs image usable out of the box
authorPetr Štetiar <ynezz@true.cz>
Sat, 30 Jan 2021 12:32:43 +0000 (13:32 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 2 Feb 2021 09:06:04 +0000 (10:06 +0100)
Currently it's not possible to boot the device with just initramfs image
without additional effort as the initramfs image doesn't contain device
tree.  Fix it by producing FIT based image which could be booted with
following commands:

 setenv bootargs earlyprintk console=ttyS0,115200
 tftpboot ${kernel_addr_r} openwrt-mvebu-cortexa9-cznic_turris-omnia-initramfs-kernel.bin
 bootm ${kernel_addr_r}

Acked-by: Klaus Kudielka <klaus.kudielka@gmail.com>
Reviewed-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry-picked from commit 337ff74894110b35b61118918b7eb30bb6e60756)

target/linux/mvebu/image/cortex-a9.mk

index 0e0bbcac45542c5695697d721909276354c50dce..5b50108d703ff4117f425ce63a6c30dd4fced458 100644 (file)
@@ -168,7 +168,8 @@ TARGET_DEVICES += globalscale_mirabox
 define Device/cznic_turris-omnia
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
-  KERNEL_INITRAMFS := kernel-bin
+  DEVICE_DTS := armada-385-turris-omnia
+  KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
   DEVICE_TITLE := Turris Omnia
   DEVICE_PACKAGES :=  \
     mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
@@ -178,7 +179,6 @@ define Device/cznic_turris-omnia
   IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
   IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
   IMAGE_NAME = $$(2)
-  DEVICE_DTS := armada-385-turris-omnia
   SUPPORTED_DEVICES += armada-385-turris-omnia
   BOOT_SCRIPT := turris-omnia
 endef