[packages] git: update to 1.7.11
authorLuka Perkov <luka@openwrt.org>
Thu, 21 Jun 2012 22:29:50 +0000 (22:29 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 21 Jun 2012 22:29:50 +0000 (22:29 +0000)
SVN-Revision: 32483

net/git/Makefile
net/git/patches/100-convert_builtin.patch

index aba71cecc7e15b727bbb7155adadb3c65aa57789..21abb28add8fc5fbc8efcc2253ac18986aeaeddb 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=1.7.10.4
+PKG_VERSION:=1.7.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://git-core.googlecode.com/files/
-PKG_MD5SUM:=68319d593d051ef76c26e945bbd2d7ac
+PKG_MD5SUM:=0beee35ec7d11756f51ca1d3ec5c0e16
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
index bee7c25c51ebb89509be897271c56aab44dbd165..0285425ccc7883e8fb8cbb83f8b317aa935bf4cf 100644 (file)
@@ -24,7 +24,7 @@
 +#include "../upload-pack.c"
 --- a/builtin.h
 +++ b/builtin.h
-@@ -150,5 +150,11 @@ extern int cmd_verify_pack(int argc, con
+@@ -151,5 +151,11 @@ extern int cmd_verify_pack(int argc, con
  extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
  extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
  extern int cmd_replace(int argc, const char **argv, const char *prefix);
  {
        const char *cmd = argv[0];
        static struct cmd_struct commands[] = {
-@@ -352,12 +352,14 @@ static void handle_internal_command(int
+@@ -353,12 +353,14 @@ static void handle_internal_command(int
                { "commit-tree", cmd_commit_tree, RUN_SETUP },
                { "config", cmd_config, RUN_SETUP_GENTLY },
                { "count-objects", cmd_count_objects, RUN_SETUP },
                { "fetch", cmd_fetch, RUN_SETUP },
                { "fetch-pack", cmd_fetch_pack, RUN_SETUP },
                { "fmt-merge-msg", cmd_fmt_merge_msg, RUN_SETUP },
-@@ -370,6 +372,8 @@ static void handle_internal_command(int
+@@ -371,6 +373,8 @@ static void handle_internal_command(int
                { "grep", cmd_grep, RUN_SETUP_GENTLY },
                { "hash-object", cmd_hash_object },
                { "help", cmd_help },
                { "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
                { "init", cmd_init_db },
                { "init-db", cmd_init_db },
-@@ -418,6 +422,7 @@ static void handle_internal_command(int
+@@ -419,6 +423,7 @@ static void handle_internal_command(int
                { "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
                { "rm", cmd_rm, RUN_SETUP },
                { "send-pack", cmd_send_pack, RUN_SETUP },
                { "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
                { "show", cmd_show, RUN_SETUP },
                { "show-branch", cmd_show_branch, RUN_SETUP },
-@@ -435,6 +440,7 @@ static void handle_internal_command(int
+@@ -436,6 +441,7 @@ static void handle_internal_command(int
                { "update-server-info", cmd_update_server_info, RUN_SETUP },
                { "upload-archive", cmd_upload_archive },
                { "upload-archive--writer", cmd_upload_archive_writer },
                { "verify-tag", cmd_verify_tag, RUN_SETUP },
 --- a/Makefile
 +++ b/Makefile
-@@ -454,15 +454,7 @@ EXTRA_PROGRAMS =
+@@ -464,15 +464,7 @@ EXTRA_PROGRAMS =
  # ... and all the rest that could be moved out of bindir to gitexecdir
  PROGRAMS += $(EXTRA_PROGRAMS)
  
+-PROGRAM_OBJS += credential-store.o
 -PROGRAM_OBJS += daemon.o
 -PROGRAM_OBJS += fast-import.o
+-PROGRAM_OBJS += http-backend.o
 -PROGRAM_OBJS += imap-send.o
+-PROGRAM_OBJS += sh-i18n--envsubst.o
 -PROGRAM_OBJS += shell.o
 -PROGRAM_OBJS += show-index.o
 -PROGRAM_OBJS += upload-pack.o
--PROGRAM_OBJS += http-backend.o
--PROGRAM_OBJS += sh-i18n--envsubst.o
--PROGRAM_OBJS += credential-store.o
 +PROGRAM_OBJS =
  
  # Binary suffix, set to .exe for Windows builds
  X =
-@@ -852,6 +844,12 @@ BUILTIN_OBJS += builtin/var.o
+@@ -900,6 +892,12 @@ BUILTIN_OBJS += builtin/var.o
  BUILTIN_OBJS += builtin/verify-pack.o
  BUILTIN_OBJS += builtin/verify-tag.o
  BUILTIN_OBJS += builtin/write-tree.o
  
  GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
  EXTLIBS =
-@@ -1447,7 +1445,7 @@ endif
+@@ -1498,7 +1496,7 @@ endif
  EXTLIBS += -lz
  
  ifndef NO_OPENSSL
        ifdef OPENSSLDIR
                BASIC_CFLAGS += -I$(OPENSSLDIR)/include
                OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
-@@ -2228,10 +2226,6 @@ endif
+@@ -2279,10 +2277,6 @@ endif
  git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
  
  git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
                $(LIBS) $(CURL_LIBCURL)
-@@ -2526,22 +2520,20 @@ endif
+@@ -2579,24 +2573,22 @@ endif
        bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
        execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
        { test "$$bindir/" = "$$execdir/" || \
 -        for p in git$X $(filter $(install_bindir_programs),$(ALL_PROGRAMS)); do \
 +        for p in $(filter $(install_bindir_programs),$(ALL_PROGRAMS)); do \
                $(RM) "$$execdir/$$p" && \
-               test -z "$(NO_CROSS_DIRECTORY_HARDLINKS)" && \
+               test -z "$(NO_INSTALL_HARDLINKS)$(NO_CROSS_DIRECTORY_HARDLINKS)" && \
 -              ln "$$bindir/$$p" "$$execdir/$$p" 2>/dev/null || \
 +              ln -s git "$$execdir/$$p" 2>/dev/null || \
                cp "$$bindir/$$p" "$$execdir/$$p" || exit; \
        } && \
        for p in $(filter $(install_bindir_programs),$(BUILT_INS)); do \
                $(RM) "$$bindir/$$p" && \
+               test -z "$(NO_INSTALL_HARDLINKS)" && \
 -              ln "$$bindir/git$X" "$$bindir/$$p" 2>/dev/null || \
                ln -s "git$X" "$$bindir/$$p" 2>/dev/null || \
                cp "$$bindir/git$X" "$$bindir/$$p" || exit; \
        done && \
        for p in $(BUILT_INS); do \
                $(RM) "$$execdir/$$p" && \
+               test -z "$(NO_INSTALL_HARDLINKS)" && \
 -              ln "$$execdir/git$X" "$$execdir/$$p" 2>/dev/null || \
                ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
                cp "$$execdir/git$X" "$$execdir/$$p" || exit; \