projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
87a91ce
)
Add swig check to prereq
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 13 Feb 2022 18:21:18 +0000
(19:21 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 13 Feb 2022 18:21:18 +0000
(19:21 +0100)
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index e1918f002787be0abae4953cfedc0cc327122ff7..bd8d7fa1d0675d2e7352952d7d662d38ffeec8e3 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-190,6
+190,9
@@
$(eval $(call SetupHostCommand,which,Please install 'which', \
/bin/which which, \
which which))
+$(eval $(call SetupHostCommand,swig,Please install 'swig', \
+ swig -python -help |grep "Python"))
+
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<