projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6ef6925
)
openssl: fix annoying build errors when changing upstream versions
author
Nicolas Thill
<nico@openwrt.org>
Sun, 17 May 2009 00:25:41 +0000
(
00:25
+0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sun, 17 May 2009 00:25:41 +0000
(
00:25
+0000)
SVN-Revision: 15880
package/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/openssl/Makefile
b/package/openssl/Makefile
index ff968c45940b6b26ccb726615b71fad90ee1d18c..f72b99bc928ccf0d2f2e4fa9d88573992b39c1d0 100644
(file)
--- a/
package/openssl/Makefile
+++ b/
package/openssl/Makefile
@@
-92,8
+92,9
@@
endef
TARGET_CFLAGS += $(FPIC)
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
+ # XXX: OpenSSL "make depend" will look for installed headers before its own,
+ # so remove installed stuff first
+ -$(SUBMAKE) -j1 clean-staging
$(MAKE) -C $(PKG_BUILD_DIR) \
MAKEDEPPROG="$(TARGET_CROSS)gcc" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \