projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9d50c38
)
ar71xx: create rescue image for the WZR-HP-G300NH
author
Gabor Juhos
<juhosg@openwrt.org>
Mon, 18 Jan 2010 16:46:57 +0000
(16:46 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Mon, 18 Jan 2010 16:46:57 +0000
(16:46 +0000)
SVN-Revision: 19223
target/linux/ar71xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/Makefile
b/target/linux/ar71xx/image/Makefile
index d3baec69e1eef950bd5be9e2f894859a46ff3c7f..09d743c479d5421c1e82c557103b3bd44775d3ab 100644
(file)
--- a/
target/linux/ar71xx/image/Makefile
+++ b/
target/linux/ar71xx/image/Makefile
@@
-129,6
+129,10
@@
define Image/Build/WZRHPG300NH
dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ( \
+ echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+ dd if=$(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ) > $(call imgname,$(1),$(2))-tftp.bin; \
fi; fi
endef