projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b688ec6
)
kernel: Adapt to move of autofs4 in kernel 4.19
author
Hauke Mehrtens
<hauke@hauke-m.de>
Fri, 2 Nov 2018 23:27:55 +0000
(
00:27
+0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 15 Dec 2018 13:28:49 +0000
(14:28 +0100)
autofs4 is now in the fs/autofs/ folder in kernel 4.19
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/fs.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/fs.mk
b/package/kernel/linux/modules/fs.mk
index 619ae90bc8800b3b321ffca987c584c901972bf6..edd2774a637cf31dcd19f95f8f2c9ca1b0066f15 100644
(file)
--- a/
package/kernel/linux/modules/fs.mk
+++ b/
package/kernel/linux/modules/fs.mk
@@
-49,8
+49,12
@@
$(eval $(call KernelPackage,fs-afs))
define KernelPackage/fs-autofs4
SUBMENU:=$(FS_MENU)
TITLE:=AUTOFS4 filesystem support
- KCONFIG:=CONFIG_AUTOFS4_FS
- FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
+ KCONFIG:= \
+ CONFIG_AUTOFS4_FS \
+ CONFIG_AUTOFS_FS
+ FILES:= \
+ $(LINUX_DIR)/fs/autofs4/autofs4.ko@lt4.18 \
+ $(LINUX_DIR)/fs/autofs/autofs4.ko@ge4.18
AUTOLOAD:=$(call AutoLoad,30,autofs4)
endef