projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
74eeb07
)
imagebuilder: don't rewrite package list output
author
Daniel Golle
<daniel@makrotopia.org>
Fri, 16 Jun 2017 23:24:43 +0000
(
01:24
+0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Wed, 13 Dec 2017 15:00:57 +0000
(16:00 +0100)
No longer rewrite opkg list output in package_list function, remove
the awk call in the pipe (which was intended for a single specific
use-case).
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit
d80d1b6c42aa663e6104f817daa5ea29d2e7073d
)
target/imagebuilder/files/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/files/Makefile
b/target/imagebuilder/files/Makefile
index 708991113af78ee560aa3a11c49ef38002bbb2ab..f61937008501deec02a8486032fa245d107c4a0e 100644
(file)
--- a/
target/imagebuilder/files/Makefile
+++ b/
target/imagebuilder/files/Makefile
@@
-141,7
+141,7
@@
package_reload:
package_list: FORCE
@$(MAKE) -s package_reload
- @$(OPKG) list --size 2>/dev/null
| awk -F" - " '{printf "%s %s %s\n", $$1, $$2, $$3}'
+ @$(OPKG) list --size 2>/dev/null
package_install: FORCE
@echo