Disable bluetooth compat for kernels older than 2.6.27
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:46:48 +0000 (15:46 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:46:48 +0000 (15:46 -0800)
The 802.11 subsystem can be built as a whole down to 2.6.25 but
bluetooth is currently only backported down to 2.6.27 so disable
bluetooth for any kernel older than 2.6.27.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index b8ed05c89fbaab2d5f2dd0f96ddb0cf92d7e78e5..9f5d08d412923da07bc175ad3a95d9df8caca1fe 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -90,12 +90,15 @@ else
  CONFIG_COMPAT_NET_USB_MODULES=m
 endif
 
+# The Bluetooth compatibility only builds on kernels >= 2.6.27 for now
+ifndef CONFIG_COMPAT_KERNEL_27
 ifeq ($(CONFIG_BT),y)
 # we'll ignore compiling bluetooth
 else
  CONFIG_COMPAT_BLUETOOTH=y
  CONFIG_COMPAT_BLUETOOTH_MODULES=m
 endif
+endif # Kernel >= 2.6.26
 
 
 # Wireless subsystem stuff