ipq40xx: wpj428: switch to zimage to fit kernel partition
authorLeon M. Busch-George <leon@georgemail.eu>
Mon, 16 Oct 2023 17:41:21 +0000 (19:41 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 21 Oct 2023 14:42:26 +0000 (16:42 +0200)
Like with some other ipq40xx devices, the kernel image size for the WPJ428
is limited in stock u-boot. For that reason, the current release doesn't
include an image for the board.
By switching to the zImage format, the kernel image size is reduced which
re-enables the build process. The image boots and behaved normally through
a few days of testing.

Before the switch to kernel version 6.1, it was possible to reduce the
image size by enough when disabling UBIFS and its otherwise unneeded
dependencies.

Signed-off-by: Leon M. Busch-George <leon@georgemail.eu>
(cherry picked from commit 2657e8cab7f3d621b66cfdd4e228da3b912af32a)

target/linux/ipq40xx/image/generic.mk

index 99a9b78b7809581a2efd9625f3011c52ac536fb4..ff5d5f26aad0128203ae62cd4186f5d9004ac0c1 100644 (file)
@@ -354,7 +354,7 @@ endef
 #TARGET_DEVICES += compex_wpj419
 
 define Device/compex_wpj428
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := Compex
        DEVICE_MODEL := WPJ428
        SOC := qcom-ipq4028