packages: intel-microcode: install the splitted ucode files
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 10 Jan 2018 20:35:29 +0000 (21:35 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Wed, 10 Jan 2018 20:40:58 +0000 (21:40 +0100)
Instead of the large microcode/microcode-64.bin, install the
splitted microcode files.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/firmware/intel-microcode/Makefile

index 541ce01970f8a4391b9812e1217f61f2023c79d0..9ab16f193e18735e4d240bdaed46b82ab827940c 100644 (file)
@@ -34,11 +34,14 @@ endef
 
 define Build/Compile
        IUCODE_TOOL=$(STAGING_DIR)/../host/bin/iucode_tool $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir $(PKG_BUILD_DIR)/intel-ucode
+       $(STAGING_DIR)/../host/bin/iucode_tool -q \
+               --write-firmware=$(PKG_BUILD_DIR)/intel-ucode $(PKG_BUILD_DIR)/$(MICROCODE).bin
 endef
 
 define Package/intel-microcode/install
        $(INSTALL_DIR) $(1)/lib/firmware/intel-ucode
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(MICROCODE).bin $(1)/lib/firmware/intel-ucode
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/intel-ucode/* $(1)/lib/firmware/intel-ucode
 endef
 
 $(eval $(call BuildPackage,intel-microcode))