projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
57781a2
)
fix libmad build when arch != mipsel
author
Nicolas Thill
<nico@openwrt.org>
Tue, 18 Oct 2005 01:58:27 +0000
(
01:58
+0000)
committer
Nicolas Thill
<nico@openwrt.org>
Tue, 18 Oct 2005 01:58:27 +0000
(
01:58
+0000)
SVN-Revision: 2173
openwrt/package/libmad/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/package/libmad/Makefile
b/openwrt/package/libmad/Makefile
index 4a979d0c072ec909fc1018f905fcd608d0045862..977248d08a0e4b92e23458f56fcc0ff7fe48c72e 100644
(file)
--- a/
openwrt/package/libmad/Makefile
+++ b/
openwrt/package/libmad/Makefile
@@
-19,6
+19,14
@@
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,LIBMAD,libmad,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+FPM:=default
+ifeq ($(ARCH),i386)
+FPM:=intel
+endif
+ifeq ($(ARCH),mipsel)
+FPM:=mips
+endif
+
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
@@
-50,7
+58,7
@@
$(PKG_BUILD_DIR)/.configured:
--enable-static \
--disable-rpath \
--with-gnu-ld \
- --enable-fpm=
mips
\
+ --enable-fpm=
$(FPM)
\
--disable-debugging \
--enable-speed \
);