openswan: update to 2.6.25
authorNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 02:48:02 +0000 (02:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 02:48:02 +0000 (02:48 +0000)
SVN-Revision: 21013

net/openswan/Makefile
net/openswan/patches/110-scripts.patch
net/openswan/patches/120-no_manpages.patch
net/openswan/patches/130-compat_net_dev_ops.patch

index d6a61ade877c0516ee37c26b3beb48150da830a9..86baa0637cf20f374e1e5734a2f322573cc0de92 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openswan
-PKG_VERSION:=2.6.24
+PKG_VERSION:=2.6.25
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openswan.org/download
-PKG_MD5SUM:=1c76b6982c05392f7c360afb92699661
+PKG_MD5SUM:=c1223786c9eb58950a4be0ab2d0a84d1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,11 +30,11 @@ endef
 
 define Package/openswan
 $(call Package/openswan/Default)
+  SUBMENU:=VPN
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS+= +kmod-openswan +libgmp +ip
   TITLE+= (daemon)
-  URL:=http://www.openswan.org/
+  DEPENDS+= +kmod-openswan +libgmp +ip
 endef
 
 define Package/openswan/description
index a32c32455ca9c181e9537d9d306dca9ec2d11e8e..bd0b049c930d5a410f813a0da31071046b21cf35 100644 (file)
@@ -8,7 +8,7 @@
 +exit 0
 --- a/programs/_plutorun/_plutorun.in
 +++ b/programs/_plutorun/_plutorun.in
-@@ -156,7 +156,7 @@
+@@ -155,7 +155,7 @@ then
                        exit 1
                fi
        else
@@ -19,7 +19,7 @@
                        exit 1
 --- a/programs/_realsetup/_realsetup.in
 +++ b/programs/_realsetup/_realsetup.in
-@@ -282,7 +282,7 @@
+@@ -282,7 +282,7 @@ case "$1" in
  
        # misc pre-Pluto setup
  
index b2fb2f6198d952d1b01cd8e2ce6e2f30cc25a91b..b3d31cf378a528dcbc44d8cd670a2eb6a8956147 100644 (file)
@@ -8,7 +8,7 @@
  CONFFILES=ipsec.conf
  EXCONFILES=ipsec.win2k.conf
  SOURCEDIR=_confread
-@@ -26,11 +25,3 @@
+@@ -26,11 +25,3 @@ CONFDFILES=clear clear-or-private privat
  
  include ${srcdir}../Makefile.program
  
@@ -22,7 +22,7 @@
 -
 --- a/programs/pluto/Makefile
 +++ b/programs/pluto/Makefile
-@@ -188,35 +188,11 @@
+@@ -188,35 +188,11 @@ doinstall: all
        $(INSTALL) $(INSTBINFLAGS) $(BINNAMEPLUTO) $(BINNAMEWHACK) $(LIBEXECDIR)
        #$(INSTALL) $(INSTSUIDFLAGS) $(BINNAMEWHACKINIT) $(LIBEXECDIR)
        if $(USE_ADNS) ; then $(INSTALL) $(INSTBINFLAGS) $(BINNAMEADNS)  $(LIBEXECDIR) ; fi
index 607753b731fd3fbf8733a22c351b192e7382ad30..97cb853b03592bafff6388c91f2486011fa78da9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/linux/include/openswan/ipsec_kversion.h
 +++ b/linux/include/openswan/ipsec_kversion.h
-@@ -339,6 +339,12 @@
+@@ -351,6 +351,12 @@
  # define HAVE_CURRENT_UID
  #endif