projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7f4bc03
)
fix KERNEL_PATCHVER for rc kernels
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 9 Mar 2009 15:05:57 +0000
(15:05 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 9 Mar 2009 15:05:57 +0000
(15:05 +0000)
SVN-Revision: 14808
include/kernel-version.mk
patch
|
blob
|
history
diff --git
a/include/kernel-version.mk
b/include/kernel-version.mk
index 003fc085b38cbb9ba5588be63128e0fbec986f7f..c3e3e140a043ad0ab40b3cd771949b0738bee0e1 100644
(file)
--- a/
include/kernel-version.mk
+++ b/
include/kernel-version.mk
@@
-40,6
+40,7
@@
LINUX_KERNEL_MD5SUM?=x
split_version=$(subst ., ,$(1))
merge_version=$(subst $(space),.,$(1))
-KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(LINUX_VERSION))))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(LINUX_VERSION))))