projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7e0c80b
)
kernel: add kmod-mvsdio MMC host controller for Marvell targets
author
Florian Fainelli
<florian@openwrt.org>
Tue, 8 Jan 2013 22:20:30 +0000
(22:20 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Tue, 8 Jan 2013 22:20:30 +0000
(22:20 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35061
package/kernel/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/other.mk
b/package/kernel/modules/other.mk
index d4983a324335cb6f089c0429fb89444641fa34c9..08b3a61a0ca86af636032b2a41fbd5497c5ccfa8 100644
(file)
--- a/
package/kernel/modules/other.mk
+++ b/
package/kernel/modules/other.mk
@@
-768,3
+768,19
@@
define KernelPackage/zram/description
endef
$(eval $(call KernelPackage,zram))
+
+
+define KernelPackage/mvsdio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell SDIO support
+ DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu +kmod-mmc
+ KCONFIG:=CONFIG_MMC_MVSDIO
+ FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+ AUTOLOAD:=$(call AutoLoad,91,mvsdio)
+endef
+
+define KernelPacakge/mvsdio/description
+ Kernel support for the Marvell SDIO controller
+endef
+
+$(eval $(call KernelPackage,mvsdio))