projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
679dbee
)
pppd: use -ffunction-sections, -fdata-sections and --gc-sections, saves 5k uncompressed
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:48:00 +0000
(12:48 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:48:00 +0000
(12:48 +0000)
SVN-Revision: 25828
package/ppp/Makefile
patch
|
blob
|
history
diff --git
a/package/ppp/Makefile
b/package/ppp/Makefile
index fba51821597e182fef07bd9294f2977c669ed087..992d966497581cb61f6d9b38af3844256df27cae 100644
(file)
--- a/
package/ppp/Makefile
+++ b/
package/ppp/Makefile
@@
-140,6
+140,9
@@
$(call Build/Configure/Default,, \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+MAKE_VARS += LDFLAGS="-Wl,--gc-sections"
+
MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
PRECOMPILED_FILTER=1 \
STAGING_DIR="$(STAGING_DIR)"