projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0de9331
)
target: add cpu flags for powerpc64
author
Florian Larysch
<fl@n621.de>
Thu, 3 Nov 2016 14:54:19 +0000
(15:54 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Tue, 24 Oct 2017 11:24:04 +0000
(13:24 +0200)
Signed-off-by: Florian Larysch <fl@n621.de>
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index c5f6e8bedeb3e1c150098d85a22d2b99dc53cef4..ef7d8555d83ff05b29d562642fad8d6e5263e39f 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-205,6
+205,10
@@
ifeq ($(DUMP),1)
CPU_CFLAGS_440:=-mcpu=440
CPU_CFLAGS_464fp:=-mcpu=464fp
endif
+ ifeq ($(ARCH),powerpc64)
+ CPU_TYPE ?= powerpc64
+ CPU_CFLAGS_powerpc64:=-mcpu=powerpc64
+ endif
ifeq ($(ARCH),sparc)
CPU_TYPE = sparc
CPU_CFLAGS_ultrasparc = -mcpu=ultrasparc