packages/keepalived: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:50 +0000 (23:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:50 +0000 (23:43 +0000)
SVN-Revision: 28920

net/keepalived/Makefile
net/keepalived/files/keepalived.init

index 4ff06739ffffeab66f28d352da4de2acac7ae1db..d7396b23b6d19201a02135237b8a427cebaf5a5c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
 PKG_VERSION:=1.1.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://www.keepalived.org/software
index 723947cc3ff57860124c2ac9b34fe3b5838eb9b5..2807f92019345cacb6e92eef346eeb5279f2c5fc 100644 (file)
@@ -1,13 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=70
 
+SERVICE_USE_PID=1
+
 start() {
-        [ -f /etc/keepalived/keepalived.conf ] && /usr/sbin/keepalived
+       service_start /usr/sbin/keepalived
 }
 
 stop() {
-        killall keepalived      
+       service_stop /usr/sbin/keepalived
 }
-