[packages] ipcad: fix compilation against librpc
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 6 Mar 2011 18:23:29 +0000 (18:23 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 6 Mar 2011 18:23:29 +0000 (18:23 +0000)
SVN-Revision: 25895

net/ipcad/Makefile

index 125cce046031d396db3ee8897c78442deedef4aa..1d541f90387c0c38c4ea68e4801ae0846b42715c 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ipcad
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap
+  DEPENDS:=+libpcap $(LIBRPC_DEPENDS)
   TITLE:=listens for traffic on the specified interfaces
   URL:=http://lionet.info/ipcad/
 endef
@@ -51,6 +51,8 @@ CONFIGURE_VARS += \
        ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
        ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
 
+TARGET_LDFLAGS += $(LIBRPC)
+
 define Package/ipcad/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/