samples/bpf: Add missing -lz to TPROGS_LDLIBS
authorToke Høiland-Jørgensen <toke@redhat.com>
Mon, 16 Dec 2019 10:24:05 +0000 (11:24 +0100)
committerAlexei Starovoitov <ast@kernel.org>
Mon, 16 Dec 2019 14:58:10 +0000 (06:58 -0800)
Since libbpf now links against zlib, this needs to be included in the
linker invocation for the userspace programs in samples/bpf that link
statically against libbpf.

Fixes: 166750bc1dd2 ("libbpf: Support libbpf-provided extern variables")
Signed-off-by: Toke Høiland-Jørgensen <toke@redhat.com>
Signed-off-by: Alexei Starovoitov <ast@kernel.org>
Tested-by: Björn Töpel <bjorn.topel@intel.com>
Link: https://lore.kernel.org/bpf/20191216102405.353834-1-toke@redhat.com
samples/bpf/Makefile

index 8003d2823fa885f6d0e0c6e966a97cda3b60cc33..227077ae66ed09dec30277e11f6ad0b108b3f1c5 100644 (file)
@@ -198,7 +198,7 @@ endif
 
 TPROGCFLAGS_bpf_load.o += -Wno-unused-variable
 
-TPROGS_LDLIBS                  += $(LIBBPF) -lelf
+TPROGS_LDLIBS                  += $(LIBBPF) -lelf -lz
 TPROGLDLIBS_tracex4            += -lrt
 TPROGLDLIBS_trace_output       += -lrt
 TPROGLDLIBS_map_perf_test      += -lrt