projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
76722ae
)
fix unpacking of .zip files
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 11 Jan 2007 19:07:12 +0000
(19:07 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 11 Jan 2007 19:07:12 +0000
(19:07 +0000)
SVN-Revision: 6083
include/unpack.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index 94124e9ec6c3fcdb3f680b146b141d176dd69bd5..e533476b5276c1b8dd91ba5aae08e1426426ab43 100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-8,7
+8,7
@@
ifeq ($(strip $(PKG_UNPACK)),)
# use existing PKG_CAT
PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
ifeq ($(PKG_CAT),unzip)
- PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)
/..
$(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)