dialog: merge r29246
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 20:51:17 +0000 (20:51 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 20:51:17 +0000 (20:51 +0000)
SVN-Revision: 30140

utils/dialog/Makefile

index a2cecbef76cc891cda8cd6e3d22d84ed7018b26b..d407ead9de642a2a6a05b8a4e545a3707779aa22 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dialog
 PKG_VERSION:=1.1-20080819
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://invisible-island.net/dialog
@@ -18,26 +18,20 @@ PKG_MD5SUM:=3caebd641a9f337b980becb4444336c5
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dialog
-       SECTION:=utils
-       CATEGORY:=Utilities
-       DEPENDS:=+libncurses
-       TITLE:=Dialog
-       URL:=http://invisible-island.net/dialog/
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libncurses
+  TITLE:=Dialog
+  URL:=http://invisible-island.net/dialog/
 endef
 
 define Package/dialog/description
-               A script-interpreter which provides a set of curses widgets.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default)
+ A script-interpreter which provides a set of curses widgets.
 endef
 
 define Package/dialog/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dialog $(1)/usr/bin
-       $(STRIP) $(1)/usr/bin/dialog
 endef
 
 $(eval $(call BuildPackage,dialog))
-