image: apk: dont fail on removing a package that doesnt exist
authorRobert Marko <robimarko@gmail.com>
Thu, 28 Nov 2024 18:16:23 +0000 (19:16 +0100)
committerRobert Marko <robimarko@gmail.com>
Fri, 29 Nov 2024 10:31:56 +0000 (11:31 +0100)
Currently, in case when a package in the device package list is marked with
the "-"" prefix meaning that its supposed to be removed for that device but
it was not actually previously built it will cause the APK to error out it
and thus image generation will also fail.

So, lets do what OPKG build step does and supress the error with the "-"
prefix in make.

Fixes: #17103
Fixes: d788ab376f85 ("build: add APK package build capabilities")
Link: https://github.com/openwrt/openwrt/pull/17106
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/image.mk

index 70dc8e069b8eeb3929b5dc83d7df00ddf3c11837..fd6f76b27711c30bea7afb05b27c458a569b5960 100644 (file)
@@ -373,7 +373,7 @@ ifneq ($(CONFIG_USE_APK),)
        rm -rf $(mkfs_cur_target_dir)
        $(CP) $(TARGET_DIR_ORIG) $(mkfs_cur_target_dir)
        $(if $(mkfs_packages_remove), \
-               $(apk_target) del $(mkfs_packages_remove))
+               -$(apk_target) del $(mkfs_packages_remove))
        $(if $(mkfs_packages_add), \
                $(apk_target) add $(mkfs_packages_add))
 else