tools/e2fsprogs: fix shell scripts under SDK
authorRosen Penev <rosenp@gmail.com>
Sun, 30 Jun 2024 16:08:40 +0000 (09:08 -0700)
committerRobert Marko <robimarko@gmail.com>
Sun, 30 Jun 2024 17:05:21 +0000 (19:05 +0200)
7c32295b0036be425ba0cd527eb06316a87d0ec0 exposed a problem where the SDK
builds these shell scripts with a nonsensical absolute path for the DIR
variable. Use sed to patch in $STAGING_DIR_HOST.

Also remove PKG_RELEASE as that is nonsensical for tools.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15841
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/e2fsprogs/Makefile

index 1025b7ec5eb16902293694230ae0f4f512c4840e..cb59f4d9ec7ed842b451c3f249dffe88b53f884d 100644 (file)
@@ -11,7 +11,6 @@ PKG_NAME:=e2fsprogs
 PKG_CPE_ID:=cpe:/a:e2fsprogs_project:e2fsprogs
 PKG_VERSION:=1.47.0
 PKG_HASH:=0b4fe723d779b0927fb83c9ae709bc7b40f66d7df36433bef143e41c54257084
-PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
@@ -38,6 +37,12 @@ define Host/Prepare
        rm -rf $(HOST_BUILD_DIR)/doc
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(SED) 's|^DIR=.*|DIR=$$$$(STAGING_DIR_HOST)/share/et|' $(STAGING_DIR_HOST)/bin/compile_et
+       $(SED) 's|^DIR=.*|DIR=$$$$(STAGING_DIR_HOST)/share/ss|' $(STAGING_DIR_HOST)/bin/mk_cmds
+endef
+
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
 endef