[packages_10.03.2] igmpproxy: merge r29083
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:17:05 +0000 (15:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:17:05 +0000 (15:17 +0000)
SVN-Revision: 30207

net/igmpproxy/Makefile
net/igmpproxy/files/igmpproxy.conf
net/igmpproxy/files/igmpproxy.init

index b420fc5629b9f435444bd7ff71120dab384391eb..43e13bb18db0b599d8b13feff79dd44f16837ac2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=igmpproxy
 PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/igmpproxy
index cffc80fc0004ad849b0c1767e274a5785d506f3f..e01b9189a44b99db6b32055151326afa0810576c 100644 (file)
@@ -27,14 +27,14 @@ quickleave
 ##------------------------------------------------------
 ## Configuration for eth0 (Upstream Interface)
 ##------------------------------------------------------
-phyint vlan0 upstream  ratelimit 0  threshold 1
+phyint br-wan upstream  ratelimit 0  threshold 1
         altnet 192.168.1.0/24
 
 
 ##------------------------------------------------------
 ## Configuration for eth1 (Downstream Interface)
 ##------------------------------------------------------
-phyint vlan1 downstream  ratelimit 0  threshold 1
+phyint br-lan downstream  ratelimit 0  threshold 1
 
 
 ##------------------------------------------------------
index 5565d3139951135f47df5ee46058e0d1a605a94f..80e1badc10c8e0bd7bf89ae26ab9b007cf3a81bd 100644 (file)
@@ -1,9 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 
 START=99
 STOP=10
 
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
 # igmpproxy supports both a debug mode and verbosity, which are very useful
 # when something isn't working.
 #
@@ -13,21 +16,16 @@ STOP=10
 # Put any debug or verbosity options into IGMP_OPTS
 #
 # Examples:
-# IGMP_OPTS="-d -v -v" - debug mode and very verbose, this will land in
+# OPTIONS="-d -v -v" - debug mode and very verbose, this will land in
 #                        stdout and not in syslog
-# IGMP_OPTS="-v" - be verbose, this will write aditional information to syslog
+# OPTIONS="-v" - be verbose, this will write aditional information to syslog
 
-IGMP_OPTS=""
-IGMP_BIN="/usr/sbin/igmpproxy"
-IGMP_CNF="/etc/igmpproxy.conf"
-PID_F="/var/run/igmpproxy.pid"
+OPTIONS=""
 
 start() {
-       echo "Starting igmpproxy"
-       start-stop-daemon -S -x $IGMP_BIN -p $PID_F -b -m -- $IGMP_OPTS $IGMP_CNF
+       service_start /usr/sbin/igmpproxy $OPTIONS /etc/igmpproxy.conf
 }
 
 stop() {
-       echo "Stopping igmpporxy"
-       start-stop-daemon -K -x $IGMP_BIN -p $PID_F -q
+       service_stop /usr/sbin/igmpproxy
 }