fix scponly compilation failure (#6986)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:23 +0000 (11:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:23 +0000 (11:03 +0000)
SVN-Revision: 20575

utils/scponly/Makefile
utils/scponly/patches/001-elif_else_replacement.patch [new file with mode: 0644]

index 02f4b86da05d10919afce3408f7f79d65ea21a96..52a14a2829a34f0b506a69563bc9ccaa7a18828b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scponly
 PKG_VERSION:=4.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/utils/scponly/patches/001-elif_else_replacement.patch b/utils/scponly/patches/001-elif_else_replacement.patch
new file mode 100644 (file)
index 0000000..e817e3e
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN scponly-4.8/helper.c scponly-4.8.new/helper.c
+--- scponly-4.8/helper.c       2008-01-15 07:26:13.000000000 +0100
++++ scponly-4.8.new/helper.c   2010-03-29 09:48:33.000000000 +0200
+@@ -230,7 +230,7 @@
+                                               return 1;
+                                       }
+                               }
+-#elif
++#else
+                               /*
+                                * make sure that processing doesn't continue if we can't validate a rsync check
+                                * and if the getopt flag is set.