[packages] openssh-server-pam: set options correctly in sshd_config when openssh...
authorPeter Wagner <​tripolar@gmx.at>
Tue, 22 Oct 2013 13:09:28 +0000 (13:09 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Tue, 22 Oct 2013 13:09:28 +0000 (13:09 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38495

net/openssh/Makefile

index 4b8a10e5d2b52bbee45d9cd9d4b51ad4f7e66c31..cbc6db4c11f9fc466c37cd2abcea1c4d3b385466 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=6.3p1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -220,6 +220,8 @@ define Package/openssh-server-pam/install
        $(INSTALL_DIR) $(1)/etc/ssh
        chmod 0700 $(1)/etc/ssh
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ssh/sshd_config $(1)/etc/ssh/
+       sed -i 's,#PasswordAuthentication yes,PasswordAuthentication no,g' $(1)/etc/ssh/sshd_config
+       sed -i 's,#UsePAM no,UsePAM yes,g' $(1)/etc/ssh/sshd_config
        $(INSTALL_DIR) $(1)/etc/pam.d
        $(INSTALL_DATA) ./files/sshd.pam $(1)/etc/pam.d/sshd
        $(INSTALL_DIR) $(1)/etc/security