AA: backport netifd from trunk
authorSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 13:03:26 +0000 (13:03 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 13:03:26 +0000 (13:03 +0000)
SVN-Revision: 36705

package/netifd/Makefile
package/netifd/files/lib/netifd/dhcp.script
package/netifd/files/lib/netifd/proto/dhcp.sh

index b5dd767f7ee2c31aaea259233cd6bc9a2a077cd6..e074ab5deca33c7ff50799afe4f830f2ea0e2816 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2013-01-29.2
+PKG_VERSION:=2013-05-17
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4bb99d4eb462776336928392010b372236ac3c93
+PKG_SOURCE_VERSION:=2f31bff38d4dc2f36006ded6b8a7d039cb569eaa
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 # PKG_MIRROR_MD5SUM:=
index d26db0f4d181dfdedde4e683ed5c1852c4845b89..b365a53528fdf4ad900ebad1f9f8b62a08825a8f 100755 (executable)
@@ -35,6 +35,30 @@ setup_interface () {
        done
        proto_send_update "$INTERFACE"
 
+       if [ -n "$IFACE6RD" -a -n "$ip6rd" ]; then
+               local v4mask="${ip6rd%% *}"
+               ip6rd="${ip6rd#* }"
+               local ip6rdprefixlen="${ip6rd%% *}"
+               ip6rd="${ip6rd#* }"
+               local ip6rdprefix="${ip6rd%% *}"
+               ip6rd="${ip6rd#* }"
+               local ip6rdbr="${ip6rd%% *}"
+
+uci -q batch <<-EOF >/dev/null
+set network.$IFACE6RD.proto=6rd
+set network.$IFACE6RD.auto=0
+set network.$IFACE6RD.peeraddr=$ip6rdbr
+set network.$IFACE6RD.ip4prefixlen=$v4mask
+set network.$IFACE6RD.ip6prefix=$ip6rdprefix
+set network.$IFCAE6RD.ip6prefixlen=$ip6rdprefixlen
+commit network
+EOF
+
+               ifdown "$IFACE6RD"
+               /etc/init.d/network reload
+               ifup "$IFACE6RD"
+       fi
+
        # TODO
        # [ -n "$ntpsrv" ] &&   change_state network "$ifc" lease_ntpsrv "$ntpsrv"
        # [ -n "$timesvr" ] &&  change_state network "$ifc" lease_timesrv "$timesvr"
index 38308785df5b30e16399e687253875b8a81b79c5..a270c681d78edab9a907ff7a7f4a1e84a9f3dcdf 100755 (executable)
@@ -12,14 +12,15 @@ proto_dhcp_init_config() {
        proto_config_add_string "vendorid"
        proto_config_add_boolean "broadcast"
        proto_config_add_string "reqopts"
+       proto_config_add_string "iface6rd"
 }
 
 proto_dhcp_setup() {
        local config="$1"
        local iface="$2"
 
-       local ipaddr hostname clientid vendorid broadcast reqopts
-       json_get_vars ipaddr hostname clientid vendorid broadcast reqopts
+       local ipaddr hostname clientid vendorid broadcast reqopts iface6rd
+       json_get_vars ipaddr hostname clientid vendorid broadcast reqopts iface6rd
 
        local opt dhcpopts
        for opt in $reqopts; do
@@ -28,6 +29,7 @@ proto_dhcp_setup() {
 
        [ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
        [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
+       [ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
 
        proto_export "INTERFACE=$config"
        proto_run_command "$config" udhcpc \