projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
06c41ce
)
package/kernel: enable CONFIG_INPUT_KEYBOARD for gpio-keys
author
Gabor Juhos
<juhosg@openwrt.org>
Wed, 29 Dec 2010 18:08:24 +0000
(18:08 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Wed, 29 Dec 2010 18:08:24 +0000
(18:08 +0000)
SVN-Revision: 24853
package/kernel/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/other.mk
b/package/kernel/modules/other.mk
index 553466d7bfd915729972b431b5f8d7db980c2649..cd3e257a89dcf6ba1a1af6d5aff005f7c67ea673 100644
(file)
--- a/
package/kernel/modules/other.mk
+++ b/
package/kernel/modules/other.mk
@@
-335,7
+335,9
@@
define KernelPackage/input-gpio-keys
SUBMENU:=$(OTHER_MENU)
TITLE:=GPIO key support
DEPENDS:= @GPIO_SUPPORT
- KCONFIG:=CONFIG_KEYBOARD_GPIO
+ KCONFIG:= \
+ CONFIG_KEYBOARD_GPIO \
+ CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
$(call AddDepends/input)