ramips: modules: add Mediatek MMC driver package
authorShiji Yang <yangshiji66@qq.com>
Tue, 9 Jul 2024 16:16:36 +0000 (00:16 +0800)
committerNick Hainke <vincent@systemli.org>
Thu, 11 Jul 2024 16:57:41 +0000 (18:57 +0200)
This is the upstream implementation of the MTK SD/SDIO/MMC card
reader driver. It is an alternative solution for the downstream
driver package "kmod-sdhci-mt7620".

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Co-authored-by: John Thomson <git@johnthomson.fastmail.com.au>
target/linux/ramips/modules.mk

index f32b82aef86810667251aa2aa343dc67be2d848f..ced479dc93e9cb76890005491977f4dcb04d8ddd 100644 (file)
@@ -4,6 +4,27 @@
 
 OTHER_MENU:=Other modules
 
+define KernelPackage/mmc-mtk
+  SUBMENU:=Other modules
+  TITLE:=MediaTek SD/MMC Card Interface support
+  DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt76x8||TARGET_ramips_mt7621) +kmod-mmc
+  KCONFIG:= \
+       CONFIG_MMC \
+       CONFIG_MMC_MTK \
+       CONFIG_MMC_CQHCI
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/cqhci.ko \
+       $(LINUX_DIR)/drivers/mmc/host/mtk-sd.ko
+  AUTOLOAD:=$(call AutoProbe,cqhci mtk-sd,1)
+endef
+
+define KernelPackage/mmc-mtk/description
+  MediaTek(R) Secure digital and Multimedia card Interface.
+  This is needed if support for any SD/SDIO/MMC devices is required.
+endef
+
+$(eval $(call KernelPackage,mmc-mtk))
+
 define KernelPackage/pwm-mediatek-ramips
   SUBMENU:=Other modules
   TITLE:=MT7628 PWM