projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f996503
)
Fix asterisk-1.4.x compilation with speex
author
Florian Fainelli
<florian@openwrt.org>
Fri, 4 Jan 2008 03:32:34 +0000
(
03:32
+0000)
committer
Florian Fainelli
<florian@openwrt.org>
Fri, 4 Jan 2008 03:32:34 +0000
(
03:32
+0000)
SVN-Revision: 10107
net/asterisk-1.4.x/Makefile
patch
|
blob
|
history
diff --git
a/net/asterisk-1.4.x/Makefile
b/net/asterisk-1.4.x/Makefile
index 11e55b44086930a9ff8a922d5f0f9cc6c8020e26..17aa9dc01d90148f9e6da63e9a462416f1600035 100644
(file)
--- a/
net/asterisk-1.4.x/Makefile
+++ b/
net/asterisk-1.4.x/Makefile
@@
-336,6
+336,8
@@
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-codec-speex),)
CONFIGURE_ARGS+= \
--with-speex="$(STAGING_DIR)/usr"
+ SITE_VARS+= \
+ ac_cv_lib_speex_speex_encode=yes
EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/include/speex
else
CONFIGURE_ARGS+= \
@@
-369,7
+371,7
@@
endif
define Build/Configure
( cd $(PKG_BUILD_DIR); ./bootstrap.sh )
- $(call Build/Configure/Default)
+ $(call Build/Configure/Default
,,$(SITE_VARS)
)
endef
define Build/Compile