projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4ee444b
)
kernel: qca-nss-dp: simplify compile arguments
author
Robert Marko
<robimarko@gmail.com>
Fri, 23 Jun 2023 16:34:39 +0000
(18:34 +0200)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Mon, 26 Jun 2023 14:17:41 +0000
(16:17 +0200)
Instead of manually passing arguments, lets just switch to using
$(KERNEL_MAKE).
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/qca-nss-dp/Makefile
patch
|
blob
|
history
diff --git
a/package/kernel/qca-nss-dp/Makefile
b/package/kernel/qca-nss-dp/Makefile
index d135ea52d4e0b420c0a535e82cfe6a58f61f53ee..3fde14560b5a04bc5bc48d3f312a537d113d7b4d 100644
(file)
--- a/
package/kernel/qca-nss-dp/Makefile
+++ b/
package/kernel/qca-nss-dp/Makefile
@@
-44,13
+44,10
@@
define Build/Configure
endef
define Build/Compile
- +$(MAKE) -C "$(LINUX_DIR)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- ARCH="$(LINUX_KARCH)" \
+ +$(KERNEL_MAKE) $(PKG_JOBS) \
+ -C "$(LINUX_DIR)" \
M="$(PKG_BUILD_DIR)" \
EXTRA_CFLAGS="$(EXTRA_CFLAGS)" SoC="$(CONFIG_TARGET_SUBTARGET)" \
- $(KERNEL_MAKE_FLAGS) \
- $(PKG_JOBS) \
modules
endef