projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ab259e8
)
make use of feature-flags: let libX11 provide the feature "drawing-backend"
author
Mirko Vogt
<mirko@openwrt.org>
Thu, 12 Nov 2009 00:51:32 +0000
(
00:51
+0000)
committer
Mirko Vogt
<mirko@openwrt.org>
Thu, 12 Nov 2009 00:51:32 +0000
(
00:51
+0000)
SVN-Revision: 18388
Xorg/xorg/lib/libX11/Makefile
patch
|
blob
|
history
diff --git
a/Xorg/xorg/lib/libX11/Makefile
b/Xorg/xorg/lib/libX11/Makefile
index 13106c18c603ea689884e7995b9e296f46f88aef..ac2b6fc66bf490ac1926f806f15a28c6a3417610 100644
(file)
--- a/
Xorg/xorg/lib/libX11/Makefile
+++ b/
Xorg/xorg/lib/libX11/Makefile
@@
-32,6
+32,12
@@
define Package/libX11
URL:=http://xorg.freedesktop.org/
endef
+define Feature/libX11
+ TARGET_NAME:=drawing-backend
+ TARGET_TITLE:=Drawing Backend
+ NAME:=libX11
+endef
+
define Build/Configure
$(call Build/Configure/Default, \
--enable-malloc0returnsnull \
@@
-72,4
+78,5
@@
define Package/libX11/install
$(1)/usr/lib/
endef
+$(eval $(call Feature,libX11))
$(eval $(call BuildPackage,libX11))