kernel: armsr: Renesas: RZ: Ethernet module and ttySC0
authorJohn Vincent <john.vincent.xa@bp.renesas.com>
Fri, 31 May 2024 13:56:24 +0000 (14:56 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 16 Jun 2024 22:10:53 +0000 (00:10 +0200)
Ethernet module enable for Renesas RZ platform
inittab fix for ttySC0

Fixes: #15284
Signed-off-by: John Vincent <john.vincent.xa@bp.renesas.com>
target/linux/armsr/base-files/etc/inittab
target/linux/armsr/image/Makefile
target/linux/armsr/modules.mk

index 87d5460d3233138052e1e77fe37fff0b9911becc..b3033a3ced3d4150df365c6484d10afa23e5592f 100644 (file)
@@ -7,3 +7,4 @@ hvc0::askfirst:/usr/libexec/login.sh
 ttymxc0::askfirst:/usr/libexec/login.sh
 ttymxc1::askfirst:/usr/libexec/login.sh
 ttymxc2::askfirst:/usr/libexec/login.sh
+ttySC0::askfirst:/usr/libexec/login.sh
index ec566c5818f8496900c61bebde00f597c24d3fbf..aec5d0a8c9b50fab3e4423a00d391784752f9b4b 100644 (file)
@@ -108,7 +108,7 @@ define Device/generic
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
        kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
        kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic \
-       kmod-bcmgenet kmod-octeontx2-net
+       kmod-bcmgenet kmod-octeontx2-net kmod-renesas-net-avb
 endef
 TARGET_DEVICES += generic
 
index d5a5d5c407f86f6718952958c30029eee4f09a29..b793f3ff491514c9cd8c3df394456d9a74347f64 100644 (file)
@@ -288,6 +288,21 @@ define KernelPackage/octeontx2-net
 endef
 $(eval $(call KernelPackage,octeontx2-net))
 
+define KernelPackage/renesas-net-avb
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Renesas network drivers
+  DEPENDS:=@(TARGET_armsr_armv8) +kmod-phylink +kmod-mii +kmod-ptp +kmod-libphy +kmod-mdio-gpio
+  KCONFIG:=CONFIG_RAVB
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/renesas/ravb.ko
+  AUTOLOAD:=$(call AutoProbe,ravb)
+endef
+define KernelPackage/renesas-net-avb/description
+  Support Renesas RZ platform Ethernet module
+endef
+$(eval $(call KernelPackage,renesas-net-avb))
+
 define KernelPackage/wdt-sp805
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ARM SP805 Watchdog