Fix nagios compilation
authorFlorian Fainelli <florian@openwrt.org>
Wed, 5 Sep 2007 13:38:00 +0000 (13:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 5 Sep 2007 13:38:00 +0000 (13:38 +0000)
SVN-Revision: 8628

net/nagios/Makefile

index 01fef8df466989791e3eadee0fb2436a8f7eabe8..f5b4ace265e931d38a4eff123c16b46afdfcfcfd 100644 (file)
@@ -35,10 +35,13 @@ define Package/send-nagios/conffiles
 /etc/send_nagios.cfg
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+
 define Build/Configure
        $(call Build/Configure/Default,\
                --with-nagios-user="root" \
                --with-nagios-group="root", \
+               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
                LIBS="-lnotimpl" \
        )
 endef