projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
32d810e
)
kernel: reduce spurious rebuilds of simple kmod-* packages
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 18 Jul 2013 16:32:07 +0000
(16:32 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 18 Jul 2013 16:32:07 +0000
(16:32 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37403
package/kernel/linux/Makefile
patch
|
blob
|
history
diff --git
a/package/kernel/linux/Makefile
b/package/kernel/linux/Makefile
index 4ca442f2a5b86f8999842b74185508e3f8adcaee..e10e99c51e3ad320f6052707b5c3c5b8aadf993a 100644
(file)
--- a/
package/kernel/linux/Makefile
+++ b/
package/kernel/linux/Makefile
@@
-18,6
+18,9
@@
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
include $(INCLUDE_DIR)/package.mk
+
+STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
+
ifeq ($(DUMP),)
-include $(LINUX_DIR)/.config
endif
@@
-32,6
+35,9
@@
endef
define Build/Compile
endef
+define KernelPackage/depends
+endef
+
CONFIG_PACKAGE_kernel=y
define Package/kernel
SECTION:=sys