[packages] babeld: cope with empty flag options
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Wed, 29 Jun 2011 07:30:23 +0000 (07:30 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Wed, 29 Jun 2011 07:30:23 +0000 (07:30 +0000)
SVN-Revision: 27304

net/babel/Makefile
net/babel/files/babeld.init

index ca0483a78aad6d79e134af915030ccf86aff8752..0eb8d2d74f2a6166539e299ee6c63a5c2be5df92 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
 PKG_VERSION:=1.1.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index 73c0c16fcde9938e5b39d944910853bbfacf5f0e..d6cd0d3af49e7cfce2e89bbcf8e7e338b4a113da 100755 (executable)
@@ -29,7 +29,7 @@ append_bool() {
        local option="$2"
        local value="$3"
        local _loctmp
-       config_get_bool _loctmp "$section" "$option"
+       config_get_bool _loctmp "$section" "$option" 0
        [ "$_loctmp" -gt 0 ] && append args "$value"
 }