uboot-stm32: bump to 2024.10
authorThomas Richard <thomas.richard@bootlin.com>
Thu, 28 Nov 2024 17:05:29 +0000 (18:05 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Dec 2024 22:48:53 +0000 (23:48 +0100)
Now the tool mkeficapsule is built by default if EFI_LOADER config is set
(which is the case by default for armv7).
This tool needs gnutls, which only exists in the packages feed.
As we don't need mkeficapsule, just disable it.

Tested on STM32MP135F-DK.

Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link: https://github.com/openwrt/openwrt/pull/17243
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-stm32/Makefile

index 58754aedd5a7c55f377a64ff30b9639bc8d39d18..6234827a28fe7c8cd053b469026118e1ca8da484 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2024.07
+PKG_VERSION:=2024.10
 PKG_RELEASE:=1
 
-PKG_HASH:=f591da9ab90ef3d6b3d173766d0ddff90c4ed7330680897486117df390d83c8f
+PKG_HASH:=b28daf4ac17e43156363078bf510297584137f6df50fced9b12df34f61a92fb0
 PKG_MAINTAINER:=Thomas Richard <thomas.richard@bootlin.com>
 
 UBOOT_USE_INTREE_DTC:=1
@@ -38,6 +38,9 @@ UBOOT_TARGETS := stm32mp135f-dk
 
 UBOOT_MAKE_FLAGS += DEVICE_TREE=$(DEVICE_TREE)
 
+UBOOT_CUSTOMIZE_CONFIG := \
+       --disable TOOLS_MKEFICAPSULE
+
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
        $(foreach img,$(UBOOT_IMAGE), \