imagebuilder: fix OPKG package_whatdepends support
authorRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 22:56:19 +0000 (23:56 +0100)
committerRobert Marko <robimarko@gmail.com>
Wed, 20 Nov 2024 08:49:21 +0000 (09:49 +0100)
Trying to use 'package_whatdepends' feature of the ImageBuilder with OPKG
will currently fail as OPKG does not support "list --depends" call at all,
it seems that this is a mixup from the original APK support commit.

So, lets restore 'package_whatdepends' support for OPKG by calling
"whatdepends -A" instead as we used to before APK support.

Fixes: d788ab376f85 ("build: add APK package build capabilities")
Link: https://github.com/openwrt/openwrt/pull/17022
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/imagebuilder/files/Makefile

index 125cc798fc8fb921db1e2e07096534a2caaacf5b..07cca7eea4a38862742f225b5d179d36c3750981 100644 (file)
@@ -349,7 +349,7 @@ ifeq ($(PACKAGE),)
 endif
        @$(MAKE) -s package_reload
 ifeq ($(CONFIG_USE_APK),)
-       @$(OPKG) list --depends $(PACKAGE)
+       @$(OPKG) whatdepends -A $(PACKAGE)
 else
        @$(APK) list --depends $(PACKAGE)
 endif