merge r16201 to 8.09
authorFlorian Fainelli <florian@openwrt.org>
Sat, 30 May 2009 08:58:18 +0000 (08:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 30 May 2009 08:58:18 +0000 (08:58 +0000)
SVN-Revision: 16202

target/linux/ar7/Makefile
target/linux/ar7/profiles/100-Annex-A.mk [new file with mode: 0644]
target/linux/ar7/profiles/100-Texas.mk
target/linux/ar7/profiles/110-Annex-B.mk [new file with mode: 0644]
target/linux/ar7/profiles/110-None.mk
target/linux/ar7/profiles/200-Texas.mk [new file with mode: 0644]
target/linux/ar7/profiles/210-None.mk [new file with mode: 0644]

index a6ffd4939888d146d7824689471f6f8fbcc16c4a..3c19000aeb680ad04eb180bbe0708396a5e1f105 100644 (file)
@@ -1,5 +1,5 @@
  
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,10 +16,10 @@ LINUX_VERSION:=2.6.26.8
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx kmod-sangam-atm-annex-a kmod-sangam-atm-annex-b
+               kmod-acx
 
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/ar7/profiles/100-Annex-A.mk b/target/linux/ar7/profiles/100-Annex-A.mk
new file mode 100644 (file)
index 0000000..3d74b5d
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-A
+  NAME:=Annex-A DSL firmware (default)
+  PACKAGES:=kmod-sangam-atm-annex-a
+endef
+
+define Profile/Annex-A/Description
+       Package set compatible with Annex-A DSL lines (most countries).
+endef
+$(eval $(call Profile,Annex-A))
+
index 267795f69239210b8e809f72b6d40c8ac2c7f7d7..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Texas
-  NAME:=Texas Instruments WiFi (default)
-  PACKAGES:=kmod-acx-mac80211
-endef
-
-define Profile/Texas/Description
-       Package set compatible with hardware using Texas Instruments WiFi cards
-endef
-$(eval $(call Profile,Texas))
-
diff --git a/target/linux/ar7/profiles/110-Annex-B.mk b/target/linux/ar7/profiles/110-Annex-B.mk
new file mode 100644 (file)
index 0000000..66692e7
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-B
+  NAME:=Annex-B DSL firmware
+  PACKAGES:=kmod-sangam-atm-annex-b
+endef
+
+define Profile/Annex-B/Description
+       Package set compatible with Annex-B DSL lines (Germany).
+endef
+$(eval $(call Profile,Annex-B))
+
index 2fcfacde9fa50cefb46f004c0109cb5935ed1235..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
diff --git a/target/linux/ar7/profiles/200-Texas.mk b/target/linux/ar7/profiles/200-Texas.mk
new file mode 100644 (file)
index 0000000..7d868bd
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+  NAME:=Texas Instruments WiFi (mac80211)
+  PACKAGES:=kmod-acx-mac80211
+endef
+
+define Profile/Texas/Description
+       Package set compatible with hardware using Texas Instruments WiFi cards
+       using the mac80211 driver.
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/ar7/profiles/210-None.mk b/target/linux/ar7/profiles/210-None.mk
new file mode 100644 (file)
index 0000000..2fcfacd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+