kconfig: split util.c out of parser.y
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Sun, 25 Aug 2019 17:28:33 +0000 (02:28 +0900)
committerMasahiro Yamada <yamada.masahiro@socionext.com>
Mon, 11 Nov 2019 11:07:03 +0000 (20:07 +0900)
util.c exists both in scripts/kconfig/ and scripts/kconfig/lxdialog.

Prior to commit 54b8ae66ae1a ("kbuild: change *FLAGS_<basetarget>.o
to take the path relative to $(obj)"), Kbuild could not pass different
flags to source files with the same basename. Now that this issue
was solved, you can split util.c out of parser.y and compile them
independently of each other.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
scripts/kconfig/Makefile
scripts/kconfig/parser.y

index ef2f2336c46960df75172e0fb5db3fda97261dec..1ce83269a5dc58eaa9aac56aebfd22d961e8a95a 100644 (file)
@@ -144,7 +144,7 @@ help:
 # ===========================================================================
 # object files used by all kconfig flavours
 common-objs    := confdata.o expr.o lexer.lex.o parser.tab.o preprocess.o \
-                  symbol.o
+                  symbol.o util.o
 
 $(obj)/lexer.lex.o: $(obj)/parser.tab.h
 HOSTCFLAGS_lexer.lex.o := -I $(srctree)/$(src)
index 60936c76865bfb07e6fb1f2767bc1514e69a6169..b3eff9613cf8e7d46be5449db5e7b8ece6343645 100644 (file)
@@ -727,5 +727,4 @@ void zconfdump(FILE *out)
        }
 }
 
-#include "util.c"
 #include "menu.c"