projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d198797
)
mgen: replace uclibc++ hacks with g++-uc wrapper
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 14 Jun 2012 16:17:08 +0000
(16:17 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 14 Jun 2012 16:17:08 +0000
(16:17 +0000)
SVN-Revision: 32355
net/mgen/Makefile
patch
|
blob
|
history
diff --git
a/net/mgen/Makefile
b/net/mgen/Makefile
index 38a79617dbb956bcddbc09d9de39408dfd365f06..1e7e30fed58affc691808899a3066e1a1f692188 100644
(file)
--- a/
net/mgen/Makefile
+++ b/
net/mgen/Makefile
@@
-37,8
+37,8
@@
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/unix \
- CC="
$(TARGET_CXX)
" \
- CPPFLAGS="$(TARGET_CPPFLAGS)
-I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++
" \
+ CC="
g++-uc
" \
+ CPPFLAGS="$(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
SYSTEM_LIBS="-ldl -lpthread -luClibc++" \
-f Makefile.linux mgen