enable threads for python
authorTim Yardley <lst@openwrt.org>
Mon, 7 May 2007 20:42:58 +0000 (20:42 +0000)
committerTim Yardley <lst@openwrt.org>
Mon, 7 May 2007 20:42:58 +0000 (20:42 +0000)
SVN-Revision: 7129

lang/python/Makefile

index 2991b647a499515c0e20b1bf712d03448276831a..996c3c0ba905fe80cd891d8b2f379397a27e1e3f 100644 (file)
@@ -28,7 +28,7 @@ PY_DISABLED_MODULES=readline pyexpat dbm gdbm bsddb \
 define Package/python
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=+uclibcxx
+  DEPENDS:=+uclibcxx +libpthread
   TITLE:=Python 2.5 programming language
   URL:=http://www.python.org/
 endef
@@ -58,7 +58,7 @@ define Build/Configure
                --disable-shared \
                --with-cxx=no \
                --sysconfdir=/etc \
-               --with-threads=no \
+               --with-threads \
                --disable-ipv6 \
                HOSTPYTHON=./hostpython \
                HOSTPGEN=./Parser/hostpgen \