From: Roman Yeryomin <leroi.lists@gmail.com>
authorMichael Büsch <mb@bu3sch.de>
Mon, 18 Oct 2010 21:35:46 +0000 (21:35 +0000)
committerMichael Büsch <mb@bu3sch.de>
Mon, 18 Oct 2010 21:35:46 +0000 (21:35 +0000)
add spandsp library package

SVN-Revision: 23523

libs/spandsp/Makefile [new file with mode: 0644]

diff --git a/libs/spandsp/Makefile b/libs/spandsp/Makefile
new file mode 100644 (file)
index 0000000..e4b689d
--- /dev/null
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=spandsp
+PKG_VERSION:=0.0.6
+PKG_RELEASE:=17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)pre17.tgz
+PKG_SOURCE_URL:=http://www.soft-switch.org/downloads/spandsp/
+PKG_MD5SUM:=cc860f77270cf3b881f8ccd42d2d0238
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libspandsp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=spandsp library
+  DEPENDS:=+libtiff
+endef
+
+CONFIGURE_ARGS+= LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib,include}
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspandsp* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+endef
+
+define Package/libspandsp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspandsp*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libspandsp))