projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7ec4ad2
)
fix download reverse depends
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 17 Mar 2009 02:37:10 +0000
(
02:37
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 17 Mar 2009 02:37:10 +0000
(
02:37
+0000)
SVN-Revision: 14907
include/download.mk
patch
|
blob
|
history
diff --git
a/include/download.mk
b/include/download.mk
index 811c42a3c37e249974b76197e4899d34f17ae7f9..78848b9c956d2004071c600bf51bcd8c8bbd1c30 100644
(file)
--- a/
include/download.mk
+++ b/
include/download.mk
@@
-5,7
+5,7
@@
# See /LICENSE for more information.
#
-DOWNLOAD_RDEP
:
=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
define dl_method
@@
-132,7
+132,9
@@
define Download
endif
)
- $(if $(DOWNLOAD_RDEP),$(DOWNLOAD_RDEP): $(DL_DIR)/$(FILE))
+ $(foreach dep,$(DOWNLOAD_RDEP),
+ $(dep): $(DL_DIR)/$(FILE)
+ )
download: $(DL_DIR)/$(FILE)
$(DL_DIR)/$(FILE):