projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7ec17bf
)
run extra scripts after package installation before image creation in the image build...
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 29 Sep 2006 20:46:20 +0000
(20:46 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 29 Sep 2006 20:46:20 +0000
(20:46 +0000)
SVN-Revision: 4879
openwrt/target/linux/imagebuilder/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/imagebuilder/Makefile
b/openwrt/target/linux/imagebuilder/Makefile
index 12bd6cbbbbff5baf8abefc6741a38c0e1784b69e..16d2b1452ef25d41e71c7cb255179fe5a53b391a 100644
(file)
--- a/
openwrt/target/linux/imagebuilder/Makefile
+++ b/
openwrt/target/linux/imagebuilder/Makefile
@@
-45,5
+45,11
@@
build:
if [ -d ./files.$(LIST) ]; then \
cp -a --remove-destination ./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
fi
+ if [ -e ./scripts/all.sh ]; then \
+ sh ./scripts/all.sh; \
+ fi
+ if [ -e ./scripts/$(LIST).sh ]; then \
+ sh ./scripts/$(LIST).sh; \
+ fi
find $(LINUX_BUILD_DIR)/root -name '.svn' || 'CVS' | xargs rm -rf
$(MAKE) -S -C image KERNEL="$(KERNEL)" BOARD="$(BOARD)" BIN_DIR="$(BIN_DIR)/$(LIST)" install