ramips: add support for ASUS 4G-AX56
authorChuncheng Chen <ccchen1984@gmail.com>
Thu, 20 Oct 2022 03:43:11 +0000 (11:43 +0800)
committerJohn Crispin <john@phrozen.org>
Fri, 13 Dec 2024 14:29:04 +0000 (15:29 +0100)
Specifications:
- Device: ASUS 4g-AX56
- SoC: MT7621AT
- Flash: 128MB
- RAM: 512MB
- Switch: 1 WAN, 4 LAN (10/100/1000 Mbps)
- WiFi: MT7905 2x2 2.4G + MT7975 2x2 5G
- LTE : Fibocom FG621-EA
- LEDs: 1x POWER (white, configurable)
1x 2.4G (white, not configurable)
1x 5G (white, not configurable)
        1x WAN (white, not configurable)
        1x 3G/4G (white, not configurable)
3x signal (white, not configurable)

Flash by U-Boot TFTP method:
- Configure your PC with IP 192.168.0.2
- Set up TFTP server and put the factory.bin image on your PC
- Connect serial port(rate:115200) and turn on AP, then interrupt "U-Boot Boot Menu" by hitting any key
   Select "2. Upgrade firmware"
   Press enter when show "Run firmware after upgrading? (Y/n):"
   Select 0 for TFTP method
   Input U-Boot's IP address: 192.168.0.1
   Input TFTP server's IP address: 192.168.0.2
   Input IP netmask: 255.255.255.0
   Input file name: openwrt-ramips-mt7621-asus_4g-ax56-squashfs-factory.bin
- Restart AP aftre see the log "Firmware upgrade completed!"

Notice:
- LTE module is disable after flash openwrt image so you must active LTE by following two AT command
   echo -e "AT+GTAUTOCONNECT=1\r\n" > /dev/ttyUSB0
   echo -e "AT+GTRNDIS=1,1\r\n" > /dev/ttyUSB0
- After finish AT command once, you don't need to input command later even if reboot/restore default

Signed-off-by: Chuncheng Chen <ccchen1984@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16752
Signed-off-by: John Crispin <john@phrozen.org>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/mt7621_asus_4g-ax56.dts [new file with mode: 0755]
target/linux/ramips/image/mt7621.mk [changed mode: 0644->0755]
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

index 341687625c8603f5b16b6777f333eaa2244ce8aa..ace29907da671533cdc97487b333f2b526c2f47f 100644 (file)
@@ -69,6 +69,7 @@ zte,mf283plus)
        ;;
 asus,rt-ax53u|\
 asus,rt-ax54|\
+asus,4g-ax56|\
 belkin,rt1800|\
 elecom,wrc-x1800gs|\
 h3c,tx1800-plus|\
diff --git a/target/linux/ramips/dts/mt7621_asus_4g-ax56.dts b/target/linux/ramips/dts/mt7621_asus_4g-ax56.dts
new file mode 100755 (executable)
index 0000000..159feeb
--- /dev/null
@@ -0,0 +1,211 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "asus,4g-ax56", "mediatek,mt7621-soc";
+       model = "ASUS 4G-AX56";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+               label-mac-device = &gmac0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+               bootargs-override = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       color = <LED_COLOR_ID_WHITE>;
+                       function = LED_FUNCTION_POWER;
+                       gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               key-restart {
+                       label = "reset";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               key-wps {
+                       label = "wps";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       mediatek,nmbm;
+       mediatek,bmt-remap-range =
+               <0x000000 0x7e0000>,
+               <0x35e0000 0x7800000>;
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               /*
+                * u-boot gets split here while keeping u-boot read-only,
+                * which allows safe usage of fw_setenv
+                */
+               partition@80000 {
+                       label = "u-boot-env";
+                       reg = <0x80000 0x60000>;
+               };
+
+               partition@e0000 {
+                       label = "nvram";
+                       reg = <0xe0000 0x100000>;
+                       read-only;
+               };
+
+               partition@1e0000 {
+                       label = "factory";
+                       reg = <0x1e0000 0x100000>;
+                       read-only;
+
+                       nvmem-layout {
+                               compatible = "fixed-layout";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               eeprom_factory_0: eeprom@0 {
+                                       reg = <0x0 0xe00>;
+                               };
+
+                               macaddr_factory_4: macaddr@4 {
+                                       reg = <0x4 0x6>;
+                               };
+
+                               precal_factory_e10: precal@e10 {
+                                       reg = <0xe10 0x19c10>;
+                               };
+                       };
+               };
+
+               partition@2e0000 {
+                       label = "factory2";
+                       reg = <0x2e0000 0x100000>;
+                       read-only;
+               };
+
+               partition@3e0000 {
+                       label = "firmware";
+                       reg = <0x3e0000 0x3200000>;
+
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "kernel";
+                               reg = <0x0 0x400000>;
+                       };
+
+                       partition@400000 {
+                               label = "ubi";
+                               reg = <0x400000 0x2e00000>;
+                       };
+               };
+
+               partition@35e0000 {
+                       label = "firmware2";
+                       reg = <0x35e0000 0x3200000>;
+               };
+
+               partition@67e0000 {
+                       label = "jffs2";
+                       reg = <0x67e0000 0x1020000>;
+               };
+
+               /* Last 8M are reserved for NMBM management (bad blocks) */
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               nvmem-cells = <&eeprom_factory_0>, <&precal_factory_e10>;
+               nvmem-cell-names = "eeprom", "precal";
+               mediatek,disable-radar-background;
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_4>;
+       nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+       status = "okay";
+       label = "wan";
+       phy-handle = <&ethphy0>;
+
+       nvmem-cells = <&macaddr_factory_4>;
+       nvmem-cell-names = "mac-address";
+};
+
+&ethphy0 {
+       /delete-property/ interrupts;
+};
+
+&switch0 {
+       ports {
+               port@1 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@4 {
+                       status = "okay";
+                       label = "lan4";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "uart2", "uart3", "jtag", "wdt";
+               function = "gpio";
+       };
+};
old mode 100644 (file)
new mode 100755 (executable)
index eb7dace..2623d89
@@ -471,6 +471,20 @@ define Device/asus_rt-ax54
 endef
 TARGET_DEVICES += asus_rt-ax54
 
+define Device/asus_4g-ax56
+  $(Device/nand)
+  $(Device/uimage-lzma-loader)
+  DEVICE_VENDOR := ASUS
+  DEVICE_MODEL := 4G-AX56
+  IMAGE_SIZE := 51200k
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+       check-size
+  DEVICE_PACKAGES := kmod-mt7915-firmware kmod-usb3 kmod-usb-serial-option \
+       kmod-usb-net-cdc-ncm
+endef
+TARGET_DEVICES += asus_4g-ax56
+
 define Device/beeline_smartbox-flash
   $(Device/nand)
   $(Device/uimage-lzma-loader)
index 17532f795b293cee715903239df5f413d56be584..f2325c83254c8e2d3cc7653df722820917b2ab2c 100755 (executable)
@@ -74,6 +74,7 @@ platform_do_upgrade() {
        asus,rt-ac85p|\
        asus,rt-ax53u|\
        asus,rt-ax54|\
+       asus,4g-ax56|\
        beeline,smartbox-flash|\
        beeline,smartbox-giga|\
        beeline,smartbox-pro|\