mt76: update to Git HEAD (2024-03-18)
authorFelix Fietkau <nbd@nbd.name>
Thu, 16 May 2024 20:15:08 +0000 (22:15 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 18 Jun 2024 13:19:51 +0000 (15:19 +0200)
a903d3169193 wifi: mt76: mt7921: fix a potential association failure upon resuming
eb0d0ce344f3 wifi: mt76: mt7921: fix suspend issue on MediaTek COB platform
841bf82e9958 wifi: mt76: fix the issue of missing txpwr settings from ch153 to ch177
ce7ccc540168 wifi: mt76: Remove redundant assignment to variable tidno
a238df940d6f wifi: mt76: mt7915: initialize rssi on adding stations
46c7d1849dbd wifi: mt76: replace skb_put with skb_put_zero
b5640b3153c7 wifi: mt76: fix tx packet loss when scanning on DBDC
7b054e5cb3af wifi: mt76: mt7915: fix mcu command format for mt7915 tx stats
3f27a64a8010 wifi: mt76: mt7915: fix bogus Tx/Rx airtime duration values
4f681a8fbc91 wifi: mt76: mt7915: fix HE PHY capabilities IE for station mode
8ede229eb8b5 wifi: mt76: mt7915: only set MT76_MCU_RESET for the main phy
2330781b8c5f wifi: mt76: mt7996: only set MT76_MCU_RESET for the main phy
e5fb6995e7eb wifi: mt76: mt7915: add support for disabling in-band discovery
b4a917417c85 wifi: mt76: mt7915: add mt7986, mt7916 and mt7981 pre-calibration
2135e201e7a9 mt76: mt7915: add fallback in case of missing precal data

Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit 85ad6b9569683d6cc5808d1797af7de0e781aa1d)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/kernel/mt76/Makefile
package/kernel/mt76/patches/0001-wifi-mt76-fix-the-issue-of-missing-txpwr-settings-fr.patch [deleted file]

index 9957c99999fa54538cbb5f0f44b9928db3ba89cb..cb71d9eeaec6fa5a5f639dc77c8a667a31489c32 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2024-02-03
-PKG_SOURCE_VERSION:=6124ea9135ed512671933f5520c46842906c78bc
-PKG_MIRROR_HASH:=acc326d7b15c9c72b494ed601300be329553f896e65c7f045e6a09327304c34a
+PKG_SOURCE_DATE:=2024-03-18
+PKG_SOURCE_VERSION:=2135e201e7a9339e018d4e2d4a33c73266e674d7
+PKG_MIRROR_HASH:=810f636c60c86e6a426c676c3bf7aaea2f711feb31f4a66889d485112b612745
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_USE_NINJA:=0
diff --git a/package/kernel/mt76/patches/0001-wifi-mt76-fix-the-issue-of-missing-txpwr-settings-fr.patch b/package/kernel/mt76/patches/0001-wifi-mt76-fix-the-issue-of-missing-txpwr-settings-fr.patch
deleted file mode 100644 (file)
index ef7816a..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 841bf82e99581f648325bee570de98892cad894f Mon Sep 17 00:00:00 2001
-From: Ming Yen Hsieh <mingyen.hsieh@mediatek.com>
-Date: Wed, 7 Feb 2024 11:31:23 +0800
-Subject: [PATCH] wifi: mt76: fix the issue of missing txpwr settings from
- ch153 to ch177
-
-Because the number of channels to be configured is calculated using the %,
-and it results in 0 when there's an exact division, this leads to some
-channels not having their tx power configured.
-
-Fixes: 7801da338856 ("wifi: mt76: mt7921: enable set txpower for UNII-4")
-Signed-off-by: Ming Yen Hsieh <mingyen.hsieh@mediatek.com>
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
- mt76_connac_mcu.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/mt76_connac_mcu.c
-+++ b/mt76_connac_mcu.c
-@@ -2104,7 +2104,7 @@ mt76_connac_mcu_rate_txpower_band(struct
-               int j, msg_len, num_ch;
-               struct sk_buff *skb;
--              num_ch = i == batch_size - 1 ? n_chan % batch_len : batch_len;
-+              num_ch = i == batch_size - 1 ? n_chan - i * batch_len : batch_len;
-               msg_len = sizeof(tx_power_tlv) + num_ch * sizeof(sku_tlbv);
-               skb = mt76_mcu_msg_alloc(dev, NULL, msg_len);
-               if (!skb) {